Roland JX-305 Displayreparatur

For the English speaking world, a summary translation can be found here

Ich habe hier einen Roland JX 305 Groovesynthesizer. Die scheinen ein wenig wie Dinosaurier: ausgestorben. Zumindest habe ich einige Berichte gefunden, nach denen die Logikboards wohl oft nach wenigen Jahren das Zeitliche gesegnet haben. Ein weiterer häufiger Fehler ist ein defektes Display, genau wie bei meinem. Es fehlen Zeilen in der Darstellung, mal mehr mal weniger. Diese Probleme sind bei der verwandten MC-505 Groovebox scheinbar exakt die selben.

Das Problem hier ist die Verbindung vom Controller zum eigentlichen Display. Sie besteht aus laminiertem Plastik, wobei diese Laminierung nicht allzu robust ist. Nachdem ich den Synthesizer soweit zerlegt hatte, dass ich an das Display ran kam, konnte ich das auch voll und ganz bestätigen. Wenn ich mit dem Fingernagel über die Verbindung drückte erschienen teilweise Zeilen wieder, bzw. andere verschwanden.

Selbst wenn ich irgendwo her so ein Verbindungskabel kriegen könnte, die Strukturen sind viel zu fein, als dass ich mit meiner Grobmotorik da etwas reparieren könnte. Folglich muss das gesamte Display ausgetauscht werden. Der Suche im Internet nach soll ein Ersatzdisplay von Roland über 100 US$ kosten, was mich – auch wenn ich das nicht nachgeprüft habe – schonmal von dieser Möglichkeit zurück schrecken lässt. Dazu kommt noch, dass es dann wieder so ein empfindliches Bauteil wär. Da such ich mir doch lieber etwas anderes.

Gefunden habe ich ein einfaches Display in grün, Kostenpunkt etwas über 7 €. Das ist schon eine ganz andere Kategorie. Gibt es auch in blau, kostet dann aber über 16 €. Das Display ist etwas anders von der Bauform als das Original, passt aber zumindest im JX-305 in die Aussparung für das Display. Die Beschaltung ist sehr ähnlich, es muss nur etwas die Reihenfolge der Leitungen getauscht werden und das Raster ist komplett anders.

Dafür habe ich den Flachbandanschluss vom Originaldisplay abgelötet.  Ein altes Flachbandkabel für ein Floppydrive wurde zerlegt und die einzelnen Adern an das Originalkabel angelötet. Da das Original mit nur 14 Leitungen auskommt, musste ich die Stromversorgung für die Hintergrundbeleuchtung von der Hauptversorgung abzweigen. Die Belegung der einzelnen Pins sind jetzt:

Pin Nummer Signal Verbunden mit Originalkabel
1 VSS 1
2 VDD 14
3 VO 13
4 RS 12
5 R/W 11
6 E 10
7 DB0 9
8 DB 8
9 DB 7
10 DB 6
11 DB 5
12 DB 4
13 DB 3
14 DB 2
15 BLA 1
16 BLK Über Vorwiderstand (je nach Helligkeitswunsch
um die 50Ω) mit 14

Das einzige, was noch nicht vollständig funktioniert, ist der Kontrast. Nur in sehr spitzen Winkeln ist etwas zu erkennen, bei geradem Blick drauf sind alle Kästchen schwarz. Soweit ich das verstehe, sollten an Pin 3 (VO) zwischen 0 und 1,5 V anliegen, gemessen sind es aber -0.53 (gegen Masse). Ich gehe im Moment davon aus, dass das Originaldisplay da mit anderen Pegeln arbeitet, da muss ich nochmal ran.

Ansonsten: Operation fast gelungen. Der Einbau erfolgt dann, wenn ich das Kontrastproblem gelöst habe.

Hilfreich war u.a.: http://www.sprut.de/electronic/lcd/

Schreibe einen Kommentar