Fairphone – Rotstich in der Mitte von Bildern

Heise schrieb in einem Kurztest, dass Fotos in der Mitte einen Rotstich hätten. Das war mir bei den ersten Bildern nicht so sehr aufgefallen, aber leider stimmt das auch für die Kamera meines Modells. Zu diesem Bild (Klick = Original)…

IMG_20140103_130205

… das Histogramm rechts oben ….

HistogrammRechtsOben

… und in der Mitte …

HistogrammMitte

Und hier ein Überblick über die Test-Bilder. Einmal alle Weißabgleiche durch, und dann die Szenen-Modi (Klick = Zip mit den Bildern des grauen Schotters, ~46MB):

RedCenterPicturesOverview

Und dann noch ein Bild mit der Frontkamera von dem Schotter. Auch hier ist ein rotes Zentrum zu sehen (Klick = Original). Wobei ich mich jetzt aber auch über das Bild wunder. Knapp 5 Megapixel? Ist das hoch gerechnet? Schließlich kann die Kamera nur 1.3 MP. Außerdem wundert mich, dass da auch diese rote Mitte da ist, sollten beide Kameras den selben Fehler haben, oder ist das ein Problem im Codec?

FrontCameraRedCenter

Wo ich denn mal darüber nachdenke: das kann eigentlich nicht der Codec sein, bei dem müssten sich ganz andere Bilder zeigen. Die Kamera-Chips würden mich auch etwas wundern, insbesondere, da beide so ein Problem zeigen. Vielleicht sind es die Linsen?

7 Gedanken zu “Fairphone – Rotstich in der Mitte von Bildern

  1. Habe grade (bei Kunstlicht) eine rein weiße Fläche photographiert und sehe auch da in der Mitte einen roten Kreis (wenn man die Sättigung hochzieht wird es deutlicher). Werde morgen mal bei Tageslicht ein paar Testphotos machen.

  2. Besonders bedenkenswert ist dabei, dass die beiden Kameras von unterschiedlichen Herstellern stammen: http://www.fairphone.com/wp-content/uploads/2013/04/20130910_List-of-Suppliers.pdf (mag die Kommunikation von Fairphone auch manchmal holprig gewesen sein, solche Listen findet man bei anderen Herstellern in der Regel nicht).
    Deswegen sollte das Problem nicht von den Kameras herrühren… Bleibt natürlich die Frage, woher der Fehler kommt.
    Möchtest Du einen entsprechenden „Problem-Report“ im Fairphone-Forum eröffnen?

    • Ah, danke, die Liste hatte ich noch gar nicht gesehen, wieder etwas, worauf ich meine Energie verwenden kann… 😉
      Wenn mir keiner zuvor kommt, mach ich morgen wegen den Kameras mal ein Thema auf.

  3. Ich denke nicht, dass die Linsen das Problem sein können – chromatische Fehler sehen anders aus (z.B. sichtbar bei starker Vergrößerung aber nicht so großflächig). Auch die Beschichtung kann es nicht sein – höchstens eine Beschichtung auf einer Optik recht nah an den Chips, ein Schutzglas oder so mit einem Fleck? Aber bei zwei Kameras (vorne und hinten) der gleiche Fehler? Das ist doch merkwürdig. Eher würde ich da auf einen Software-Filter tippen, der den Farbstich vor dem Speichern in alle Bilder operiert… aber das ist jetzt auch nur geraten.

    • Es ist auf jeden Fall nicht der typische Fall von chromatischer Aberration, wenn Du Dich darauf beziehst.
      Dass beide Kameras dieses Problem haben, wundert mich eben sehr. Software-Filter fände ich unwahrscheinlicher, der Mediatek-Chipsatz elaubt den „Engineer-Modus“, mit dem auch „RAW“ Bilder gemacht werden können. Auch wenn ich noch nicht ganz die Dekodierung von diesen raus habe, sieht man dennoch, dass die Farbverschiebung auch auf diesen Aufnahmen ist. Bleibt natürlich auch die Frage, wie roh diese Daten wirklich sind.
      Ich probier aber morgen mal die verschiedenen Färb-Effekte aus, die hab ich bisher ignoriert.

  4. Artefakte treten beim photographieren einer weißen Fläche ohne Farbkorrektur und im Negativmodus auf (dann halt invertiert). Bei den anderen Effekten nicht, auch nicht bei Sepia und Aqua. Könnte also doch ein Softwareproblem sein.

    • Ist meiner Meinung nach kein Argument. Die verfügbaren Effekte sind „Mono“, „Sepia“, „Negative“, „Aqua“, „Blackboard“ und „Whiteboard“.

      „Mono“, „Blackboard“, „Whiteboard“ und „Sepia“ sind farblose Effekte, also kann der Rotstich nicht zu sehen sein („Sepia“ = „Mono“ mit Einfärbung).
      „Aqua“ nimmt einfach nur den blauen Kanal, somit ist jedes rot ausgefiltert
      Somit bleiben „None“ und „Negative“, die überhaupt rot mit im Ergebnis haben.

Schreibe einen Kommentar